Ih 1086

Discuss your favorite brand and how to fix it.
Ky cowboy
Trail Boss
Trail Boss
Posts: 334
Joined: Thu Apr 30, 2015 12:52 pm
Location: Western kentucky

Ih 1086

Postby Ky cowboy » Tue Apr 03, 2018 6:26 am

Since i replaced the injector pump on it last fall it started running hot and blowing white smoke. I know this sounds like a head gasket, but could it be just a little out of time or somehow turned up inside the pump. I just find it strange that it didn't do it till I put the new pump on. It's holding good oil pressure and there's no coolant in oil. Can't tell if it's leaking coolant because it does have a small valve that's on the side of the block that has a slow drip and i havent fixed yet. I ordered 2 new thermostasts and will change them when they get here. Motor starts and runs fine just white smoke. It does blow a puff of black smoke when you first start it, then turns white. Any thoughts and ideas appreciated.
0 x

User avatar
sim.-ang.king
GURU
GURU
Posts: 4118
Joined: Tue Aug 10, 2010 10:17 pm
Location: Southern IL
Contact:

Re: Ih 1086

Postby sim.-ang.king » Tue Apr 03, 2018 9:11 am

Does it only smoke at idle, or all the way through the rpm range?
0 x
"Benign Neglect" -Dun

Ky cowboy
Trail Boss
Trail Boss
Posts: 334
Joined: Thu Apr 30, 2015 12:52 pm
Location: Western kentucky

Re: Ih 1086

Postby Ky cowboy » Tue Apr 03, 2018 9:53 am

All t he way thru rpm range but it is significantly worse at lower rpms
0 x


Return to “Trucks, Tractors and Machinery”

Who is online

Users browsing this forum: No registered users and 2 guests