Vermeer Hay Roller Monitor

Discuss your favorite brand and how to fix it.
Post Reply
User avatar
pricefarm
GURU
GURU
Posts: 1365
Joined: Sun Jul 07, 2013 5:05 pm
Location: Southwest Va
Has thanked: 45 times
Been thanked: 27 times

Vermeer Hay Roller Monitor

Post by pricefarm » Sun Sep 01, 2019 2:17 pm

My 554xl has the basic Acutie monitor with it. Does anyone know anything about these and how to trouble shoot. My give all kinds of error codes. It thinks the bale has reach the preset size as soon as the roll starts sometimes. Then it thinks the roll has meet the oversize roll size then starts tying. It also gives a error that there is a short in ground on the tie arms. I have looked over all the wiring and can not see any bad wires. Iam thinking maybe it’s the monitor it self because of all the different codes it is throwing. Anyone have any ideas ? Yesterday when I was rolling the monitor would turn it self off and would not tie a roll. Lucky I was able to unhook it and tie them manually with just a toggle switch



User avatar
1982vett
GURU
GURU
Posts: 8900
Joined: Sun Feb 03, 2008 7:57 pm
Location: Central Texas
Has thanked: 74 times
Been thanked: 137 times

Re: Vermeer Hay Roller Monitor

Post by 1982vett » Sun Sep 01, 2019 2:20 pm

Could be the pins in the connectors. My controller stoped auto tying. Traced it down to the loose connector.
Aug 7, 2019 22:51GMT -5 the illustrious potentate said:
Because you have the freedom to say what you think, doesn't always mean that you should.

The right to speak freely is not free of consequences.

Atimm693
Trail Boss
Trail Boss
Posts: 481
Joined: Fri Oct 14, 2016 8:44 am
Has thanked: 2 times
Been thanked: 40 times

Re: Vermeer Hay Roller Monitor

Post by Atimm693 » Sun Sep 01, 2019 3:50 pm

I would check over the ground wires. Make sure the one from the monitor to the tractor battery is good and tight, and the one from the monitor harness to the baler chassis is good. Bad grounds can cause some very odd issues.

User avatar
jltrent
GURU
GURU
Posts: 3206
Joined: Sun Aug 25, 2013 9:04 pm
Location: Virginia
Has thanked: 266 times
Been thanked: 261 times

Re: Vermeer Hay Roller Monitor

Post by jltrent » Mon Sep 02, 2019 7:17 am

Last year I had to replace the sensor on the bale size indicator on my Vermeer and this year I had to replace the sensor on the tying arm. I looked the wiring over and imagined everything. After replacing those it was instant fix. If the monitor will boot up ok and give an error code it may not be it, although I am not an expert on them. As mentioned I would check the pins closely as I spray WD-40 on mine often and it helps lube and clean the pins for a smoother fit.

Just a SWAG it sounds like the bale size sensor on the variable chamber arm.

Post Reply